Preserve VAT isn’t working

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #105124
    brandonkramer
    Participant

    I’m using this plugin and its working great! except for one thing:

    I have ‘Preserve VAT in selected countries’ enabled on ‘Comma separated list’ and have selected NL (Netherlands) in this list.

    In the checkout when someone fills in his Belgium (BE) VAT number and it gets validated the order wil get charged 0% tax which is good, but when the user confirms the order, it suddenly brings back the tax (21%) and the user has to pay the full amount with tax included.

    Am I doing something wrong?

    • This topic was modified 11 months, 1 week ago by Omar Dabbas.
    #105125
    Tom Anbinder
    Moderator
    Plugin Support

    Hi,

    Thanks for reporting – as “Comma separated list” option was only added in latest plugin version 1.4.0, it may be that I didn’t test it properly. Will check that as soon as possible.

    #105126
    Tom Anbinder
    Moderator
    Plugin Support

    Hi again,

    I’ve just tried to reproduce the error on my test server, but unfortunately didn’t succeed – 0% VAT remains after I’m confirming the order. Maybe I could log in to your site’s admin to check what’s going on? If that is possible – my private email is [email protected]. If sharing an account is not an option – could you please for a start try setting “Preserve VAT in selected countries” option to “Disabled” to be sure that this is connected.

    #105127
    Tom Anbinder
    Moderator
    Plugin Support

    Thanks for logins. After logging to your server I was able to replicate the error. The problem occurs only when VAT ID is entered without country code (i.e. “Allow VAT number input without country code” plugin option must be enabled). Already fixing this…

    #105128
    Tom Anbinder
    Moderator
    Plugin Support

    Fixed in plugin v1.4.1.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.