Showing specific attributes only

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #105711
    blankPareidolia
    Participant

    Hello,

    I need to make a variation only feed with some attributes pulled from the parent and others from the variation itself.

    Snippet:
    [alg_product_list_attribute name=”pa_color” use_parent_id=”yes”]
    [alg_product_list_attribute name=”pa_size”]

    However, this pulls the parent data for both attributes, i.e: Color: Red / Size: 40, 41, 42, etc
    I have also tried use_parent_id=”no” for Size with the same result.

    Whereas if use:
    [alg_product_list_attribute name=”pa_color”]
    [alg_product_list_attribute name=”pa_size”]

    It returns Color: [empty] / Size: 40

    What this feed requires is color pulled from the parent and size pulled from the variation and then the same for several other attributes, but no matter how much I play around with use_parent_id it always gives me all data from parent or all data from variation.

    Best regards

    #105712
    blankWPWhale
    Moderator

    Hi Pareidolia,

    Is Color in this case an attribute that’s used for variation? Or just in the parent product?

    I mean having 2 colors & 2 sizes will produce 4 product variations? Just trying to understand how the final feed should look like.

    Omar

    #105713
    blankPareidolia
    Participant

    Only size is used for variations, color and every other attribute are just for the parent.

    For example the parent attributes might be:
    Size: 40, 41, 42
    Color: Red
    Material: Leather
    Brand: ABC

    The variations in that case are:
    40
    41
    42

    And what I’m trying to get in the variation only feed is just one size per item with some parent attributes. If I don’t attach use_parent_id to any shortcode I get the correct size attribute but all parent-only attributes are empty. If I do attach use_parent_id in even one shortcode then all shortcodes output the parent attribute, including the one for size which means it lists all sizes instead of one for each item.

    I hope that makes sense.

    #105714
    blankPareidolia
    Participant

    Quick update:

    I deleted that feed and started again and it just works, I’m not sure what I missed the first time.

    #105715
    blankWPWhale
    Moderator

    Glad to know it works fine now.

    Let me know if you need any further help.

    Omar

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.