Test emails not sending automatically

Top WooCommerce & WordPress Plugins Forums Custom Emails for WooCommerce Test emails not sending automatically

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #134242
    blankJesse
    Participant

    I set up a custom email that should only be sent with 1 specific product and not send the normal email. I can’t seem to get the custom one to send at all unless I manually send it. it does however block the normal one from sending.

    #134405
    blankMoshtafizur
    Moderator
    Plugin Support

    Hi there,

    Please check if WP Cron is enabled on your site. You can do that in “WooCommerce > Status > System status > WordPress cron”.

    If WP Cron is disabled, please try one of these two solutions:

    enable WP cron – check if you have define( ‘DISABLE_WP_CRON’, true ); in your wp-config.php file, or

    switch the “Scheduler” option from “WP Cron” to “Action Scheduler” (in “WooCommerce > Settings > Custom Emails > General > Scheduler”). The option is available since the plugin v2.7.0.

    #134452
    blankJesse
    Participant

    I tried both, but no luck. It’s still not working.

    Any other suggestions?

    #134540
    blankMoshtafizur
    Moderator
    Plugin Support

    Hi there,

    I have escalated this with our development team. They will back to you as soon as possible,

    Kind regards.

    #134972
    blankJesse
    Participant

    Any updates?

    #135103
    blankTom Anbinder
    Moderator
    Plugin Support

    Hi, Jesse,

    Sorry for not getting back to you sooner.

    Could you please enable the “Debug” checkbox in “WooCommerce > Settings > Custom Emails > General > Advanced Options”, trigger automatic email, and then check today’s log in “WooCommerce > Status > Logs” (the log will start with custom-emails-for-woocommerce-...). What does it say?

    P.S. If this won’t help – would it be possible to share access to your site, so I could log in and check what’s going on (my email is [email protected])?

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.