Why are not all my products displayed on the stock report?

Top WooCommerce & WordPress Plugins Forums Cost of Goods for WooCommerce Why are not all my products displayed on the stock report?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #89880
    Jeanine Hamans
    Participant

    Hello, I have purchased your plugin and I am trying to export the stock report under Woocommerce> Reports > Stock > Costs of goods.

    However, not all my products are displayed here or exported. It says that I only have 139 products, but I have over 300 active products. These products all have a price, cost price and stock enabled. Why are they not showing up on the summary or export?

    #89881
    Jeanine Hamans
    Participant

    Hi there, I found out that is has to do with products that have a selling price of €0. But also when I set the selling price at €0,02, €0,10 or anything else, these products do not show up in the report. It is very important that these products show up as well. For example, these are shipping materials that are part of the stock, but customers do not pay for them. But they have to be added to the total stock overview. How to fix this?

    #89882
    Zohaib
    Participant

    Hi Jeanine,

    First, in the plugin’s settings, Tools & Reports > Analytics > Stock tab, Enable the options here. Then in your WordPress dashboard go to Analytics > stock

    You will find products that don’t have a price but have a cost here. You can export this report.

    Please let me know if you continue having trouble with this.

    #89883
    Pablo
    Moderator
    Plugin Support

    Hi Jeanine,

    Sorry for the long delay, but actually you were right. Products having costs or prices with decimal places after zero were not getting displayed on that report. We will fix that in the next version.

    Anyway, you can use our other report on WooCommerce Analytics to see the products there.

    Let me know if you need more help.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.