Why aren’t emails being sent to users?

Top WooCommerce & WordPress Plugins Forums Email Verification for WooCommerce Why aren’t emails being sent to users?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #101560
    Sebastien CAND
    Participant

    Hi,

    Is it possible to achieve the following?

    • On the checkout page: when a new customer validate the order, the process is blocked and an email verification is sent.
    • When he activates his account (via the link sent):
      • he receives the email informing him that the account has been created (from woocommerce)
      • he is redirected to the checkout page and he is now allowed to confirm his order and if everything is ok continue to the thank you page.

    I tried several options… Right now, a message is displayed to log in and activate the email in order to place the order. But no email is sent. I would like the email to be sent while on the checkout page and to create automatically the account before the order is processed…
    In this case only verified customers can validate an order and create an account. Is it possible?

    Thank you in advance for your support,

    Best Regards,

    #101561
    Zohaib
    Participant

    Hi Sebastien,

    If the customer does not checkout, then no account is created. This is a WooCommerce limitation. Because the account is not created, there is no trigger for the email verification to be sent.

    However, there are a couple of workaround that you could try.

    1. You could ensure that customers create an account while checking out. The option is under: WooCommerce > Accounts and Privacy > Account Creation >  Allow customers to create an account during checkout

    2. You can block the checkout process for unverified users. The option is under:
    Blocking > Block checkout

    3. You can block order emails until the customer verifies his email. To do this you can use the option under:
    Blocking > Block order emails

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.