Why does “Text in product summary/description” not work for variations?

Top WooCommerce & WordPress Plugins Forums Maximum Products per User for WooCommerce Why does “Text in product summary/description” not work for variations?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #100578
    Tom Veal

    I am a paying customer.

    “Text in product summary/description” does not work for variations.
    Settings > Maximum Products per User > Frontend > Single product page

    For the options “Text in product Summary” and “Text in product description”
    These options do not work when you apply a limit to a product variation.

    To replicate
    Theme: Twenty Twenty-one
    Product ID #23 (Parent product)
    Variation ID #26
    Variation ID #29

    General > Use variations > Enabled
    Limits > Per product > Enabled
    Frontend > Single product page > Text in product Summary/Description
    Formula > Enabled > [alg_wc_mppu limit=”10″ user_id=”2″ product_id=”26″]

    When you view Product #23, “Text in product Summary” message is not displayed. When you change the variation options to the correct variation of #26, the message is still not displayed.

    If you change the shortcode formula to [alg_wc_mppu limit=”10″ user_id=”2″ product_id=”23, 26″] the message is displayed but it does not update when you change the variation options and the message is for the #23 parent product.

    The “Text in product Summary/Description” should recognise when variations are updated on the single-product and show the relevant message. As do the Price, Stock and Additional Information is updated when you change variation from the dropdown.

    Please can you advise about this bug and the possibility of making this feature work with variations?

    Many thanks,

    WPFactory Plugins
    Plugin Author

    Hello Tom,

    I just released a new version (v3.5.4) with a new option for you:
    – Frontend > Product limit message > Variations

    Please update the plugin, give it a try and let me know if it works for you 😉

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.