Why is the wg_cog_cost field for COGS not being updated with new products?

Top WooCommerce & WordPress Plugins Forums Cost of Goods for WooCommerce Why is the wg_cog_cost field for COGS not being updated with new products?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #89966
    Nat
    Guest

    Hello, I am finding that frequently COGS is not being copied across automatically with new products to the _wc_cog_cost field.

    This is extremely inconvenient as I frequently need to download all my products and manually copy across the COGS to the _wc_cog_cost to sync with my reporting software.

    For example I created 20 new products and 18 costs copied across but 2 didn’t and I didn’t realise until after they were purchased. Is there a way to fix this or have the plugin use the _wc_cog_cost field by default?

    #89967
    Pablo
    Moderator
    Plugin Support

    Hello Nat,

    Please try to enable both “Compatibility > Metorik” options and let me know if it helps.

    #89968
    Nat
    Guest

    Hello, this is still not fixed. It is enabled and has always been enabled.

    However any new items or variations I add does NOT update, I need to download products csv and update manually. Can somebody please reach out to me as plugin is not working as and will need a refund

    #89969
    Pablo
    Moderator
    Plugin Support

    Hi Nat,

    I’m sorry it’s not working for you as expected, but I just tested here and it seems to be working just fine. Can you please explain what exactly is the process you’re running where _wc_cog_cost meta does not get updated or created? Maybe with a video if possible?

    Any chance that the meta is being created as it should but the problem is related to your reporting software or with the way your site is syncing with it?

    #89970
    Nat
    Guest

    Hi Paulo thanks for the reply.
    I add a new item or variation, publish it.
    I then export products to check if it has updated.
    The cost price will be In the custom meta but not copied across.
    I then have to update the missing values on the csv, and upload back to the site.

    #89971
    Pablo
    Moderator
    Plugin Support

    Can you please explain this part better? “The cost price will be In the custom meta but not copied across.”

    If the cost price is in the custom meta (_wc_cog_cost) then it should be working.

    Can you please create/share an admin account to your server (WP and preferably FTP), so I could log in and check what’s going on? If that’s the case, please send a message to [email protected].

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.