Why isn’t the “Activate” message appearing on the “My Account” page?

Top WooCommerce & WordPress Plugins Forums Email Verification for WooCommerce Why isn’t the “Activate” message appearing on the “My Account” page?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #101343


    I have been trying a lot of different things and I’m at my wit’s end.

    I’m unable to get the Activate message to show up on the My Account page (as so many have before me).

    What I would like:

    ONLY enable “Prevent login after checkout” and “Block checkout”. Have the Activate reminder on the My Accounts page until the user has activated their email.
    At this point, there is no message to activate email anywhere (at any point in registration process), so user has no clue to even check their email.

    What I have tried:

    I was able to make the message appear by manually appending “?alg_wc_ev_activate_account_message=XX” to the URL in the My Accounts page. Thus I believe it is simply a matter of making this append properly.
    To this end, I have already tried enabling “Redirect on failure” and setting the custom URL to: “www.XXX.com/my-accounts/?alg…..” (this doesn’t work)

    Other things I’ve tried (including your previous fixes):

    If I ALSO enable “Prevent login after register” then the plugin logs out after registering and posts the correct message. However, I don’t want this UX and thus I NEED to be able to see the message without this behavior.
    The different CSS snippets you’ve given before (doesn’t work)
    Enabling the “Block unverified login” option (works, but I don’t want this behavior)
    Enabling the “Logout users” options (works, but I don’t want this behavior)

    So basically – to get the behavior that I want, I need to enable options which I don’t want. Please help me show the message with only the “Prevent login after checkout” and “Block checkout” options.

    Thank you for your help (and the plugin)!



    There are a couple of more settings that you could try.

    Please try and change:
    – Advanced > Authenticate filter

    If it doesn’t work, please try one more option
    – General > Redirect on failure (Available in V 2.1.0 of the plugin)

    Even if the Custom redirect URL option is empty, there will be no problem. A “?alg_wc_ev_email_verified_error” argument will be added to the URL that could help you displaying the message.

    Please let me know if you continue having trouble with this.


    Hello Zohaib,

    Thank you for the pointers! I tried all of them out and no luck.




    Is it possible for you to share your WordPress dashboard access and we can take a look for you then? You can send your details to [email protected]


    Hello Zohaib,

    I’ve decided to leave out this functionality for now, it seems too complicated and have spent too much time on it. I will reach out if I need it in the future.

    Thank you!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.