XML not working properly

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #105518
    firuz
    Guest

    Screenshots:
    https://prnt.sc/g1vu3i
    https://prnt.sc/g1vv33

    • This topic was modified 1 year, 2 months ago by Omar Dabbas.
    #105519

    Hi Firuz,

    Will check that first thing tomorrow morning.

    Best regards,
    Tom

    #105520

    Hi again,

    I’ve just tested on my server and I’m not sure I can reproduce the issue. I’ve tried some different configurations, and basically the result of [alg_product_stock_availability] shortcode depends on what you set in product’s edit page “Inventory” tab. “Out of stock” is shown always as it should be, and “In stock” depends on “Enable stock management at product level” and “Stock quantity” options. As far as I figured out – depending on those settings sometimes shortcode outputs empty string if product is in stock (but for example no “Stock quantity” is set). So as a solution, I’m thinking about adding on_empty attribute to the shortcode, so you could use it something like:

    [alg_product_stock_availability on_empty="In stock"]

    Please let me know what you think.

    Best regards,
    Tom

    #105521
    firuz
    Guest

    Here settings “Invertory” page.
    http://prntscr.com/g23ryn
    And:
    http://prntscr.com/g23sdw
    http://prntscr.com/g23sjs
    Please help me, i can give you admin page access, if you have a free time.
    Sorry for my bad english. Thank you for answer. Best support.

    #105522

    I meant “Inventory” tab on each product’s edit page.

    I’ve just sent you an email.

    Best regards,
    Tom

    #105523

    Hi,

    As suggested on_empty attribute was added to all shortcodes in plugin v1.2.1.

    Best regards,
    Tom

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.