Why can’t we get the link to verify users?

Top WooCommerce & WordPress Plugins Forums Email Verification for WooCommerce Why can’t we get the link to verify users?

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
  • #101485
    Adam Etkin

    We’re evaluating the plugin for our site, but cannot get the link in the user email to verify the account or to re-send the verification email to work.

    In the email to the new customer we use:

    validate your email


    we use

    click here to re-send it.

    Any assistance is appreciated!


    Plugin Support


    We’ve received your questions on wp.org as well but I’m not sure if I understood your issue.

    By default, this plugin sends the verification link in a separate email.
    If you want to send the link into the new user account email you should:

    – Disable “Email > Activation email > Send as a separate email”

    And the option “Email > Activation email > Email content” doesn’t need to be changed.

    Let me know if it helps

    Adam Etkin

    I do not understand how to format the link in the email. What should the href= be that will pull in the customer info?

    Adam Etkin

    Maybe this will help. Screen shot of email a new user would get when they register below. How do I properly code the “validate your email” link? Nothing I’ve tried works.

    Adam Etkin

    Dang. Screenshot here


    Plugin Support

    This should be the content of Email > Activation email > Email content option:

    For security, please <a href="%verification_url%" target="_blank">validate your email</a> before logging in to your account.

    On top of that, you’re trying to use our shortcode to display the activation link precisely on the Customer new account email correct?

    You can use the [alg_wc_ev_email_content_placeholder] shortcode to append the verification email to some custom email template.
    In order to use it, it’s necessary to:

    – Enable the option Email > Activation email > Fine tune activation email placement
    – Disable the option Email > Activation email > Send as a separate email
    – Most probably the option Emails > Activation email > Email template should be set as Plain

    Are you trying to use the shortcode in a custom email template in php directly? Or are you using some visual editor plugin to create the custom email? If you’re using a plugin like that, it should work as simple as adding the shortcode there. If you’re using it in a php file, you have to use it like this:

    echo do_shortcode( '[alg_wc_ev_email_content_placeholder]' );
    Adam Etkin

    I must be missing something very obvious, because I still am not able to make this work.

    Are you saying to LITERALLY use "%verification_url%" and/or [alg_wc_ev_email_content_placeholder] ?

    This results in an email that displays like this:

    With a hyperlink that points to validate your email

    I’m using Email Customizer for WooCommerce  to customize the emails. Screen shot of the content entry section of that plugin:


    Plugin Support

    Adam, would it be possible for you to create/share an admin account to your server (WP and preferably FTP), so I could login and check what’s going on?
    If that’s the case, please send a message to [email protected]

    Plugin Support


    I think I may have an answer for the issue.
    You’re trying to add our shortcode on your custom template created by the Email Customizer plugin, right?

    This should work, but according to their “Pro features” page, it’s only possible to add third-party shortcodes if you use the Pro version of the Email Customizer plugin, and you only have the free version.

    Let me know if it helps.

    Adam Etkin

    I’ll look into that, although I still do not understand why I can’t just insert a regular hyperlink. What about adding a “resend verification email” link on a web page?

    Adam Etkin

    Upgraded the email customizer to pro and I do not see anything that helps solve this. It allows the insertion of a “custom hook” but I do not know how that related to your shortcode.

    Adam Etkin

    I believe I’ve made some progress, but still need some help. Remember, I’m not a proficient coder, which is why I’m using plugins.

    Added the following using code snippets:

    do_action ( "alg_wc_ev_activation_email_content_placeholder", $email->object );

    Created a custom hook in email customizer template:


    Now when a new user creates an account they get one email and the “Please click here to verify your email” link does appear and seems to be formatted properly.

    However, clicking the link results in the following:

    Error: Activation failed, please contact our administrator. You can resend the email with verification link by clicking here.

    Clicking the link to resend the email does not work. No email is received.

    I really hope you’re able to help me finally get this to work.


    Adam Etkin

    Can you please help me figure this out?

    Adam Etkin

    I ended up paying to upgrade to the PRO version in the hopes it might provide a solution. Unfortunately not. I hope you can help address my concerns. I really feel it is important for customers to only be sent one email on a new account creation. Why confuse them and make them do extra work? Having said that, if only 2 emails work properly, so be it.

    See below. Hopefully the clues I provide can lead to a solution.

    Enabling the verification link within the new account email simply does not work.
    -When the nonce link is inside the new account email they all end with “n0-” and do not work
    -HOWEVER, the working links in the separate verification email all end with “J9”
    If we enable 2 separate emails, and set it so the new account email is not sent until the email is verified, all the links work as expected, BUT the customer is getting the new account email at the same time as the verification email and then AGAIN after verification.
    -This is a problem because a) it’s annoying to the customer, and b) the woocommerce emails automatically create a password that is in the email and the customer now has 2 different randomly generated passwords.
    I thought I found a clever solution, by deactivating the woocommerce new account email and creating a verification email in the plugin settings using html. This ALMOST worked, but the tags to pull in the woocommerce userID, password, and anything else you might want to include do not appear. Can’t very well send a new account email without a password.

    I have checked all my plugin settings many times and they are correct. It seems as if the only way for the plugin to “work” is to have both emails sent at the same time. Right now I cannot see how anyone is successfully using your plugin in any other way and upgrading to paid PRO offers no advantages.

    Can you deliver what you promise regarding this plugin?

    Plugin Support


    We’re checking your issue.
    As soon as we have news we’ll let you know

Viewing 15 posts - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.