Why can’t I edit my variable products anymore?

WPFactory Plugins – Empower Stores Success Forums Cost of Goods for WooCommerce Why can’t I edit my variable products anymore?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #89256
    lior
    Participant

    Hello,

    When we are trying to add variation to existing variable product (with cost of goods already entered) –
    the page stuck and the product is not editable anymore and needs to be deleted
    here is a error message I get from wordpress:

    אירעה שגיאה מסוג E_ERROR בשורה 176 בקובץ /home/thethirdeyeco/public_html/wp-content/plugins/cost-of-goods-for-woocommerce/includes/class-alg-wc-cost-of-goods-core.php. הודעת שגיאה: Uncaught Error: Call to a member function get_parent_id() on bool in /home/thethirdeyeco/public_html/wp-content/plugins/cost-of-goods-for-woocommerce/includes/class-alg-wc-cost-of-goods-core.php:176
    Stack trace:
    #0 /home/thethirdeyeco/public_html/wp-content/plugins/cost-of-goods-for-woocommerce/includes/class-alg-wc-cost-of-goods-core.php(206): Alg_WC_Cost_of_Goods_Core->get_product_cost(10268)
    #1 /home/thethirdeyeco/public_html/wp-content/plugins/cost-of-goods-for-woocommerce/includes/class-alg-wc-cost-of-goods-core.php(237): Alg_WC_Cost_of_Goods_Core->get_product_profit(10268)
    #2 /home/thethirdeyeco/public_html/wp-content/plugins/cost-of-goods-for-woocommerce/includes/class-alg-wc-cost-of-goods-core.php(219): Alg_WC_Cost_of_Goods_Core->get_variable_product_html(2780, ‘profit’)
    #3 /home/thethirdeyeco/public_html/wp-content/plugins/cost-of-goods-for-woocommerce/includes/class-alg-wc-cost-of-goods-core.php(270): Alg_WC_Cost_of_Goods_Core->get_product_profit_html(2780)
    #4 /home/thethirdeyeco/public_html/wp-incl

    Please help

    #89257
    Tom Anbinder
    Moderator
    Plugin Support

    Hi Lior,

    Please give me a minute to check this – I will get back to you shortly.

    #89258
    Tom Anbinder
    Moderator
    Plugin Support

    Hi again,

    I was unable to reproduce the issue on my server, however, I’ve just released new plugin version 1.4.1, where I’ve added additional safe-checks to the code. Could you please update and let me know if this fixes the issue.

    #89259
    lior
    Participant

    Hi Tom,

    Sorry for my late reply, Yes the update solve the issue, thanks!!!

    #89260
    Tom Anbinder
    Moderator
    Plugin Support

    Hi Lior,

    Great, happy to hear it’s solved. Please let me know if you need anything else. And if you like the plugin, please consider leaving me a rating.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.