Why do the image title and alt-text not seem to be getting renamed?

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #100015
    Erica
    Participant

    Image title and alt-text do not seem to be getting renamed when a post name/permalink is changed. I’ve selected those options in the plugin settings.

    #100016
    Pablo Pacheco
    Participant

    Hi Erica,

    What image title option are you referring to exactly?
    I’m not sure if we have such option

    Regarding alt-text, the only alt options we have for now can only change the alt for new added attachment. Do you need to update it when a post name changes? I can try to take a look

    #100017
    Erica
    Participant

    Thanks for your quickly reply. I’m talking about the image Title setting, as shown in the media library, right below the alt text, and above the description and caption (screenshot)

    #100018
    Erica
    Participant

    Sorry, and yes, it would be terrific to have the alt text (and Title) update when/if the post name changes.

    #100019
    Pablo Pacheco
    Participant

    Hi Erica,

    Good news 🙂
    I just released a new version (1.2.6) with some new options for you:

    – Update alt attribute on filename update
    – Update media title on filename update/ on new attachment upload

    Let me know if it works for you 😉

    #100020
    Erica
    Participant

    Excellent! I just tried it though, and it doesn’t appear to be working on my site. I’m renaming an image, and it’s not changing the image title or alt text showing in the media library.

    #100021
    Erica
    Participant

    I should clarify, it is at least not working when I rename an existing flie. Image title/alt text is not changing then.

    #100022
    Pablo Pacheco
    Participant

    Hum,

    Would it be possible for you to create/share an admin account to your server (WP and preferably FTP), so I could login and check what’s going on?
    If that’s the case, please send a message to [email protected]

    #100023
    Erica
    Participant

    This doesn’t seem to be working anymore when an image is uploaded to our CPT. I’m finding photos in our media library that aren’t renamed. When I change the permalink in the file, it renames, but the alt/meta once again isn’t updating. These users don’t have direct access to the media library in the wp-admin navigation, only through the featured image upload in the CPT.

    #111261
    Moshtafizur
    Moderator
    Plugin Support

    Hi Erica,

    We wanted to know if you still need help with the issue.

    Kind regards,
    Moshtafizur

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.