Why is the “Extra cost of shipping class” not working as expected?

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #90064
    Tony Grefweberg
    Participant

    Hi, nice plugin but I have one problem. I’m using extra cost by shipping class and if a customer buys 4 of the same product the shipping cost is only calculated once and that’s fine. But if a customer buys 4 different products with the same shipping class then cost is calculated 4 times instead of just one. Can you fix this please. Thanks! / Tony

    #90065
    Pablo
    Moderator
    Plugin Support

    Hi Tony,

    I believe you’re right. For the time being, we’re calculating the shipping class cost for each different item. I believe the issue you’re reporting wouldn’t apply to the “Percent cost”, right? As its calculation depends on the product total.

    But for the “Fixed cost”, I think it makes sense. I’ll create a new option for it then, where it’s going to be possible to calculate it for each product or each shipping class.

    Let me know your thoughts.

    #90066
    Tony Grefweberg
    Participant

    Hi, when will this option be available? Thanks! / Tony

    #90067
    Pablo
    Moderator
    Plugin Support

    Hi Tony,

    Let me just know what you think of my question. The feature you’re asking for is oriented to the fixed cost only and not the percent, correct?

    #90068
    Tony Grefweberg
    Participant

    Correct, just for fixed cost, that will be great! I also answered on the e-mails that where sent out when you replied on my first question, but maybe you don’t get those? Thanks / Tony

    #90069
    Pablo
    Moderator
    Plugin Support

    Hi Tony,

    Maybe I didn’t get it. Ok, no problem. I created a new option for you that you can find in the “Shipping classes” section. The option is “Fixed cost calculation“. In your case, you should set it as “Per shipping class“.

    Please, update the plugin to version 2.6.3 and let me know if it works for you ๐Ÿ˜‰

    #90070
    Tony Grefweberg
    Participant

    Just tried it, works perfect! Thanks and great support! / Tony

    #90071
    Pablo
    Moderator
    Plugin Support

    Great!

    In that case, please consider leaving a review here or here if you are enjoying the plugin/support. It would be much appreciated ๐Ÿ™‚

    See you.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.