How can I limit products per membership plan?

Home Forums Maximum Products per User for WooCommerce How can I limit products per membership plan?

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #101048
    Ubaidullah Malik
    Guest

    Hello
    My Scenario is as follows.I have membership plans A,B and C. I want A(monthly) members to download 10 products per day.B(Yearly) members to download 50 products per day and C(Lifetime) members to download unlimited product per day.

    As of now I am using the formula section with code as follows:
    [alg_wc_mppu limit=”10″ membership_plan=”free-membership”] Have seen above comments that says need tag id can you let me know a little bit about tag to be used if the solution is this.
    Here the quantity of particular product is getting changed but I want overall 10 different products to be purchased per day.
    Also the message in the frontend section says
    [alg_wc_mppu_customer_msg bought_msg=”You can only buy maximum %limit% of %product_title% (you’ve already bought %bought%).” not_bought_msg=”You can only buy maximum %limit% of %product_title%.”]
    I want to show {You have purchased 1 product 9 products is remaining}

    #101049
    Moshtafizur
    Moderator
    Plugin Support

    Hello Ubaidullah,

    I hope you are well today.

    You may limit a user with a specific membership to only purchasing a maximum of 10 items from your store using our plugin. However, you cannot compel the user to purchase 10 different products. For instance, if tagA has a restriction of 10, the consumer may buy a specific product from tagA 10 times, or he can buy 10 different products from tagA.

    But if that’s okay for you, then please follow the general instructions below to achieve that:

    1. At first, please navigate to WooCommerce > Settings > Maximum Products per User > General and set Mode to Product Quantities. Then set the Date range to This day and Order statuses to appropriate values.

    2. Next, go to the Limits section and check Per product tag checkbox.

    3. Then assign all the products in your store to a particular tag and let’s say the tag’s ID is 20.

    4. Finally, go to the Formula section and enable the Limit by formula option. Then, you may use shortcodes such as:

    [alg_wc_mppu limit=”10″ term_id="20" membership_plan=”free-membership”]

    Now regarding the second question, in the plugin’s settings, under the Frontend section, in the Customer message field, please paste the following message instead.

    [alg_wc_mppu_customer_msg bought_msg="You have purchased %bought% product %remaining% products is remaining" not_bought_msg="You can only buy maximum %limit% of %product_title%."]

    I hope you found this information useful. If you have any other questions or need assistance, please contact us.

    Kind regards,
    Moshtafizur

    #103021
    Agnieszka Michalak
    Participant

    Dear Support,

    I have the same issue. I’ve done the above, even I tagged them the same – with the tag “20”. To have a clear picture on what I’m doing wrong

    [alg_wc_mppu limit=”5″ term_id=”20″ membership_plan=”basic”]
    [alg_wc_mppu limit=”10″ term_id=”20″ membership_plan=”pro”]

    Also, as per your advice in another topic I enabled the below options:

    – Frontend > Validate on Add to cart
    – Frontend > Cart notice > Enable
    – Frontend > Block checkout page

    But still I can proceed with adding to cart, with checkout and with completing an order ABOVE the set up limits.

    Maybe there is something we have to change in Woocommerce Memberships plugin?
    I work in local environment, does it affect your plugin?

    I’ve been trying to fix this for three days now. Please help!

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.